<?xml version="1.0" encoding="UTF-8"?><rss xmlns:dc="http://purl.org/dc/elements/1.1/" xmlns:content="http://purl.org/rss/1.0/modules/content/" xmlns:atom="http://www.w3.org/2005/Atom" version="2.0"><channel><title><![CDATA[MIB comiling nightmare (part 01)]]></title><description><![CDATA[<p dir="auto">Hello,<br />
First off, Netxms is a really great tool !<br />
I use it for our school (32 Cisco SG300 series switches, 1 Catalys c2960 , )<br />
but the power comes from DCI and thus MIB..<br />
that last one is really problematic ...<br />
i have literary try for hours to compile MIB for our Cisco SMB switchen (SG300 series ) and our UPS ..<br />
after hours of trying, manual fix syntax error --&gt; <a href="http://www.ibr.cs.tu-bs.de/bin/smitools.cgi" rel="nofollow ugc">http://www.ibr.cs.tu-bs.de/bin/smitools.cgi</a> upload mib file to this site to test the syntax ..<br />
At last i have deleted the mib files and the compiled one in de mibs folder (/usr/share/netxms/mibs)<br />
just adding the MIB for the UPS (infosec) UPSmib.txt ,  not compiling needing SNMPv2-SMI.txt and RFC115-SMI.txt and RFC1682.txt ..<br />
after searching on the internet found these but do not work .. pff<br />
After testing the UPSmib.txt there was a problem with the "COMPANYMIB: ERROR 001: Import symbol "MODULE-IDENTITY" unresolved "<br />
follow this website to trey the module-identity error.. fix some syntax but nothing helps .. <a href="http://www.muonics.com/Docs/MIBSmithy/UserGuide/moduleids.php" rel="nofollow ugc">http://www.muonics.com/Docs/MIBSmithy/UserGuide/moduleids.php</a><br />
Try to Resolved this issue with adding the MODULE-IDENTITY but still this error .. adding the Cisco sg300 MIB errors ...<br />
Who has expert skils to fix this ... or help me ?<br />
<strong>Is there a way to download the correct MIB that are included in the Netxms distribution ? or how to restore de default MIB ?</strong><br />
i attached the MIB for Cisco SMB and UPS Infosec<br />
Also i found this link of de MIB of Netxms but how do you download all this MIB ? without one by one opening an copy-past tot text file ??<br />
<a href="http://git.netxms.org/public/netxms.git/tree/refs/heads/develop:/contrib/mibs?js=1" rel="nofollow ugc">http://git.netxms.org/public/netxms.git/tree/refs/heads/develop:/contrib/mibs?js=1</a><br />
Ho to convert MIB V1 or V2 to V3 so that Netxms accept it ?<br />
i have the latest NETXMS server installed on Linux<br />
Use management console on windows workstations and android.</p>
<p dir="auto">The Cisco MIB zip file is not uploading ! error 413 here is my onedrive link to the file ! --&gt; <a href="https://1drv.ms/u/s!Aj037gJtNd7Bpe0gaqkQuZqp2XsRMg" rel="nofollow ugc">https://1drv.ms/u/s!Aj037gJtNd7Bpe0gaqkQuZqp2XsRMg</a></p>
<hr />
<p dir="auto"><a href="/assets/uploads/files/smf/0000000003777-infosec-mib-original.zip">infosec-mib-original.zip</a></p>
]]></description><link>https://forum.netxms.org/topic/5307/mib-comiling-nightmare-part-01</link><generator>RSS for Node</generator><lastBuildDate>Fri, 13 Nov 2026 14:42:39 GMT</lastBuildDate><atom:link href="https://forum.netxms.org/topic/5307.rss" rel="self" type="application/rss+xml"/><pubDate>Tue, 31 Oct 2017 22:26:21 GMT</pubDate><ttl>60</ttl><item><title><![CDATA[Reply to MIB comiling nightmare (part 01) on Thu, 14 Oct 2021 14:51:14 GMT]]></title><description><![CDATA[<p dir="auto">Hi Victor,</p>
<p dir="auto">I was talking to you about the Juniper Switches Vlans.. I found the mib for it and I'm getting the data when I do the walk, but the data is not going to the Vlan field on the interfaces menu. the OID is .1.3.6.1.4.1.2636.3.48.1.3.1.1.3<br />
With this we can get the Vlan Tags. For the HPs I have everything looks good, just the Junipers are not getting the Vlans. Is there something I can do, collect data maybe?</p>
<p dir="auto">Thanks.</p>
]]></description><link>https://forum.netxms.org/post/30640</link><guid isPermaLink="true">https://forum.netxms.org/post/30640</guid><dc:creator><![CDATA[albertosilva]]></dc:creator><pubDate>Thu, 14 Oct 2021 14:51:14 GMT</pubDate></item><item><title><![CDATA[Reply to MIB comiling nightmare (part 01) on Sun, 05 Nov 2017 23:40:29 GMT]]></title><description><![CDATA[<p dir="auto">Thank You allot,</p>
<p dir="auto">No i can use DCI on my switches and UPS.</p>
]]></description><link>https://forum.netxms.org/post/23333</link><guid isPermaLink="true">https://forum.netxms.org/post/23333</guid><dc:creator><![CDATA[yordi]]></dc:creator><pubDate>Sun, 05 Nov 2017 23:40:29 GMT</pubDate></item><item><title><![CDATA[Reply to MIB comiling nightmare (part 01) on Thu, 02 Nov 2017 08:46:12 GMT]]></title><description><![CDATA[<p dir="auto">Hi,</p>
<p dir="auto">you can restore original MIBs by downloading source package and extracting MIBs - they are under contrib/mibs. You don't need RFC-1628 MIB - it is already included.</p>
<p dir="auto">Seems that whoever builds Infosec MIB you have provided just took some template without much thinking - leaving "companyName" placeholder instead of replacing it with actual company name. I changed it to "infosec" and MIB name to INFOSEC-UPS, and fixed few other errors. Correct MIB attached.</p>
<p dir="auto">Best regards,<br />
Victor</p>
<hr />
<p dir="auto"><a href="/assets/uploads/files/smf/0000000003778-INFOSEC-UPS.txt">INFOSEC-UPS.txt</a></p>
]]></description><link>https://forum.netxms.org/post/23309</link><guid isPermaLink="true">https://forum.netxms.org/post/23309</guid><dc:creator><![CDATA[victor]]></dc:creator><pubDate>Thu, 02 Nov 2017 08:46:12 GMT</pubDate></item></channel></rss>