Skip to content
  • Categories
  • Recent
  • Tags
  • Popular
  • Users
  • Groups
Skins
  • Light
  • Brite
  • Cerulean
  • Cosmo
  • Flatly
  • Journal
  • Litera
  • Lumen
  • Lux
  • Materia
  • Minty
  • Morph
  • Pulse
  • Sandstone
  • Simplex
  • Sketchy
  • Spacelab
  • United
  • Yeti
  • Zephyr
  • Dark
  • Cyborg
  • Darkly
  • Quartz
  • Slate
  • Solar
  • Superhero
  • Vapor

  • Default (Flatly)
  • No Skin
Collapse
Brand Logo

NetXMS Forum

B

badland

@badland
Unfollow Follow
About
Posts
10
Topics
1
Shares
0
Groups
0
Followers
0
Following
0

Posts

Recent Best Controversial

  • Ошибка при компиляции mib'a от ATI
    B badland
    Support (Russian)

    Проверил на errors must be fixed. Самое смешное, что к этому файлу вопросов никаких  🙂 а вот к зависимым... но к этой строчке проблем ноль.


  • Ошибка при компиляции mib'a от ATI
    B badland
    Support (Russian)

    Прошу прощения, не будет.

    Теперь компилю мибы от AT-9800 SERIES. Мибы взяты с диска от AT-9816GB (древнего). Закинул эти мибы к тем, что компилил выше. Сразу ошибка на файле: atrouter.mib. Порыскал, нашел поновее. Все равно ошибка на том же месте:

    C:\NetXMS\var\mibs\atrouter.txt: ERROR 003: Parser error - syntax error, unexpected DEFINITIONS_SYM, expecting  CASEFIRST_IDENT_SYM in line 4

    4-я строчка - то: DEFINITIONS ::= BEGIN

    Кусок кода:

           ALLIEDTELESYN-MIB
    -- ATRouter Private MIB Version 1.35  24/May/2005
    
            DEFINITIONS ::= BEGIN
    
            IMPORTS
               enterprises, IpAddress, Counter
                    FROM RFC1155-SMI
               DisplayString, ifIndex
                    FROM RFC1213-MIB
               TRAP-TYPE
                    FROM RFC-1215
               OBJECT-TYPE
                    FROM RFC-1212;
    
    --  Textual convention for an interface index type which may not reference an actual member of ifTable, in which case the value
    --  zero should be used.
        InterfaceIndexOrZero ::= INTEGER (0..2147483647)
    
            -- define the top of the alliedTelesyn MIB.
    
            alliedTelesyn            OBJECT IDENTIFIER ::= { enterprises 207 }
            products                 OBJECT IDENTIFIER ::= { alliedTelesyn 1 }
            mibObject                OBJECT IDENTIFIER ::= { alliedTelesyn 8 }
    
            bridgeRouter             OBJECT IDENTIFIER ::= { products 1 }
            centreCOM-AR300Router    OBJECT IDENTIFIER ::= { bridgeRouter 8 }
            centreCOM-AR720Router    OBJECT IDENTIFIER ::= { bridgeRouter 11 }
            centreCOM-AR300LRouter   OBJECT IDENTIFIER ::= { bridgeRouter 12 }
            centreCOM-AR310Router    OBJECT IDENTIFIER ::= { bridgeRouter 13 }
            centreCOM-AR300LURouter  OBJECT IDENTIFIER ::= { bridgeRouter 14 }
            centreCOM-AR300URouter   OBJECT IDENTIFIER ::= { bridgeRouter 15 }
            centreCOM-AR310URouter   OBJECT IDENTIFIER ::= { bridgeRouter 16 }
            centreCOM-AR350Router    OBJECT IDENTIFIER ::= { bridgeRouter 17 }
            centreCOM-AR370Router    OBJECT IDENTIFIER ::= { bridgeRouter 18 }
            centreCOM-AR330Router    OBJECT IDENTIFIER ::= { bridgeRouter 19 }
            centreCOM-AR395Router    OBJECT IDENTIFIER ::= { bridgeRouter 20 }
            centreCOM-AR390Router    OBJECT IDENTIFIER ::= { bridgeRouter 21 }
            centreCOM-AR370URouter   OBJECT IDENTIFIER ::= { bridgeRouter 22 }
            centreCOM-AR740Router    OBJECT IDENTIFIER ::= { bridgeRouter 23 }
            centreCOM-AR140SRouter   OBJECT IDENTIFIER ::= { bridgeRouter 24 }
            centreCOM-AR140URouter   OBJECT IDENTIFIER ::= { bridgeRouter 25 }
            centreCOM-AR320Router    OBJECT IDENTIFIER ::= { bridgeRouter 26 }
            centreCOM-AR130SRouter   OBJECT IDENTIFIER ::= { bridgeRouter 27 }
            centreCOM-AR130URouter   OBJECT IDENTIFIER ::= { bridgeRouter 28 }
            centreCOM-AR160Router    OBJECT IDENTIFIER ::= { bridgeRouter 29 }
            at-AR740RouterDC         OBJECT IDENTIFIER ::= { bridgeRouter 43 }
            centreCOM-AR120Router    OBJECT IDENTIFIER ::= { bridgeRouter 44 }
            at-AR410Router           OBJECT IDENTIFIER ::= { bridgeRouter 47 }
            at-AR725Router           OBJECT IDENTIFIER ::= { bridgeRouter 48 }
            at-AR745Router           OBJECT IDENTIFIER ::= { bridgeRouter 49 }
            at-AR410v2Router         OBJECT IDENTIFIER ::= { bridgeRouter 50 }
            at-AR410v3Router         OBJECT IDENTIFIER ::= { bridgeRouter 51 }
            at-AR725RouterDC         OBJECT IDENTIFIER ::= { bridgeRouter 52 }
            at-AR745RouterDC         OBJECT IDENTIFIER ::= { bridgeRouter 53 }
            at-AR450Router           OBJECT IDENTIFIER ::= { bridgeRouter 54 }
            at-AR450DualRouter       OBJECT IDENTIFIER ::= { bridgeRouter 55 }
            at-AR440Router           OBJECT IDENTIFIER ::= { bridgeRouter 59 }
            at-AR441Router           OBJECT IDENTIFIER ::= { bridgeRouter 60 }
            at-AR442Router           OBJECT IDENTIFIER ::= { bridgeRouter 61 }
            at-AR443Router           OBJECT IDENTIFIER ::= { bridgeRouter 62 }
            at-AR444Router           OBJECT IDENTIFIER ::= { bridgeRouter 63 }
            at-AR420Router           OBJECT IDENTIFIER ::= { bridgeRouter 64 }
    		at-AR550Router			 OBJECT IDENTIFIER ::= { bridgeRouter 73 }
    		at-AR551Router			 OBJECT IDENTIFIER ::= { bridgeRouter 74 }
    		at-AR552Router			 OBJECT IDENTIFIER ::= { bridgeRouter 75 }
    
            routerSwitch             OBJECT IDENTIFIER ::= { products 14 }
            at-Rapier24              OBJECT IDENTIFIER ::= { routerSwitch 1 }
            at-Rapier16fSC           OBJECT IDENTIFIER ::= { routerSwitch 2 }
            at-Rapier16fVF           OBJECT IDENTIFIER ::= { routerSwitch 3 }  -- deprecated
            at-Rapier16fMT           OBJECT IDENTIFIER ::= { routerSwitch 4 }
            at-Rapier48              OBJECT IDENTIFIER ::= { routerSwitch 5 }
            at-Rapier8t8fSC          OBJECT IDENTIFIER ::= { routerSwitch 6 }
            at-Rapier8t8fSCi         OBJECT IDENTIFIER ::= { routerSwitch 7 }
            at-Rapier8t8fMT          OBJECT IDENTIFIER ::= { routerSwitch 8 }
            at-Rapier8t8fMTi         OBJECT IDENTIFIER ::= { routerSwitch 9 }
            at-Rapier8fSC            OBJECT IDENTIFIER ::= { routerSwitch 10 }
            at-Rapier8fSCi           OBJECT IDENTIFIER ::= { routerSwitch 11 }
            at-Rapier8fMT            OBJECT IDENTIFIER ::= { routerSwitch 12 }
            at-Rapier8fMTi           OBJECT IDENTIFIER ::= { routerSwitch 13 }
            at-Rapier16fMTi          OBJECT IDENTIFIER ::= { routerSwitch 14 }
            at-RapierG6              OBJECT IDENTIFIER ::= { routerSwitch 15 }
            at-RapierG6SX            OBJECT IDENTIFIER ::= { routerSwitch 16 }
            at-RapierG6LX            OBJECT IDENTIFIER ::= { routerSwitch 17 }
            at-RapierG6MT            OBJECT IDENTIFIER ::= { routerSwitch 18 }
            at-Rapier16fSCi          OBJECT IDENTIFIER ::= { routerSwitch 19 }
            at-Rapier24i             OBJECT IDENTIFIER ::= { routerSwitch 20 }
            at-Rapier48i             OBJECT IDENTIFIER ::= { routerSwitch 21 }
            at-Switchblade4AC        OBJECT IDENTIFIER ::= { routerSwitch 22 }
            at-Switchblade4DC        OBJECT IDENTIFIER ::= { routerSwitch 23 }
            at-Switchblade8AC        OBJECT IDENTIFIER ::= { routerSwitch 24 }
            at-Switchblade8DC        OBJECT IDENTIFIER ::= { routerSwitch 25 }
            at-9816GF                OBJECT IDENTIFIER ::= { routerSwitch 26 }
            at-9812TF                OBJECT IDENTIFIER ::= { routerSwitch 27 }
            at-9816GB                OBJECT IDENTIFIER ::= { routerSwitch 28 }
            at-9812T                 OBJECT IDENTIFIER ::= { routerSwitch 29 }
    		at-8724XL                OBJECT IDENTIFIER ::= { routerSwitch 30 }
    		at-8748XL                OBJECT IDENTIFIER ::= { routerSwitch 31 }
    		at-8724XLDC              OBJECT IDENTIFIER ::= { routerSwitch 32 }
    		at-8748XLDC              OBJECT IDENTIFIER ::= { routerSwitch 33 }
    		at-9816GB-DC             OBJECT IDENTIFIER ::= { routerSwitch 34 }
    		at-9812T-DC              OBJECT IDENTIFIER ::= { routerSwitch 35 }
    		at-8824                  OBJECT IDENTIFIER ::= { routerSwitch 36 }
    		at-8848                  OBJECT IDENTIFIER ::= { routerSwitch 37 }
    		at-8824-DC               OBJECT IDENTIFIER ::= { routerSwitch 38 }
    		at-8848-DC               OBJECT IDENTIFIER ::= { routerSwitch 39 }
            at-8624XL-80             OBJECT IDENTIFIER ::= { routerSwitch 41 }
    		at-8724XL-80             OBJECT IDENTIFIER ::= { routerSwitch 42 }
    		at-8748XL-80             OBJECT IDENTIFIER ::= { routerSwitch 43 }
    		at-8948EX                OBJECT IDENTIFIER ::= { routerSwitch 44 }
    		at-8948MX                OBJECT IDENTIFIER ::= { routerSwitch 45 }
    		at-8624T2M               OBJECT IDENTIFIER ::= { routerSwitch 46 }
    		at-Rapier24i-DC-NEBS     OBJECT IDENTIFIER ::= { routerSwitch 47 }
    		at-8724XL-DC-NEBS        OBJECT IDENTIFIER ::= { routerSwitch 48 }
    		at-9924T                 OBJECT IDENTIFIER ::= { routerSwitch 49 }
    		at-9924SP                OBJECT IDENTIFIER ::= { routerSwitch 50 }
    		at-9924T-4SP             OBJECT IDENTIFIER ::= { routerSwitch 51 }
    		at-9924TEMC              OBJECT IDENTIFIER ::= { routerSwitch 53 }
    		at-8724MLB               OBJECT IDENTIFIER ::= { routerSwitch 55 }
    		at-8624POE               OBJECT IDENTIFIER ::= { routerSwitch 56 }
    		at-86482SP               OBJECT IDENTIFIER ::= { routerSwitch 58 }
    
            brouterMib               OBJECT IDENTIFIER ::= { mibObject 4 }
            atRouter                 OBJECT IDENTIFIER ::= { brouterMib 4 }
    

    Фаил приложен.


    atrouter.zip


  • Ошибка при компиляции mib'a от ATI
    B badland
    Support (Russian)

    Выкладываю дополненую и исправленую сборку мибов для x900 серии, основной костяк взят с диска к at-9924t. NetXMS её кушает.  ;D


    at-9924t-x900series-mibs.rar


  • Ошибка при компиляции mib'a от ATI
    B badland
    Support (Russian)

    Как я понял, это стандартный миб: взял этот миб с cisco 2-й версии. Атишный выкинул из сборки. Наконец-то все собралось, только во время компиляции проскочило такое:

    V2ADMIN-MIB
    V2ADMIN-MIB: WARNING 006: Cannot resolve data type "TruthValue" for object "notifyConfirm"

    Файлик циски приложил.


    IEEE8023-LAG-MIB.zip


  • Ошибка при компиляции mib'a от ATI
    B badland
    Support (Russian)

    Спасибо, скушал.

    Но опять запнулся на следующем:

    IEEE8023-LAG-MIB: ERROR 001: Import symbol "BITS" unresolved

    C:\NetXMS\var\test>C:\NetXMS\bin\nxmibc.exe -d C:\NetXMS\var\mibs -o C:\NetXMS\v
    ar\mibs\netxms.mib -z
    NetXMS MIB Compiler  Version 0.2.21
    Copyright (c) 2005, 2006 Victor Kirhenshtein
    
    Parsing source files:
       C:\NetXMS\var\mibs\ARCADA-MIB.txt
       C:\NetXMS\var\mibs\at-boards.txt
       C:\NetXMS\var\mibs\at-dhcp.txt
       C:\NetXMS\var\mibs\at-envmon.txt
       C:\NetXMS\var\mibs\at-epsr.txt
       C:\NetXMS\var\mibs\at-eth.txt
       C:\NetXMS\var\mibs\at-file.txt
       C:\NetXMS\var\mibs\at-flash.txt
       C:\NetXMS\var\mibs\at-install.txt
       C:\NetXMS\var\mibs\at-interface.txt
       C:\NetXMS\var\mibs\at-loader.txt
       C:\NetXMS\var\mibs\at-pae.txt
       C:\NetXMS\var\mibs\at-pim.txt
       C:\NetXMS\var\mibs\at-ping.txt
       C:\NetXMS\var\mibs\at-product.txt
       C:\NetXMS\var\mibs\at-qos.txt
       C:\NetXMS\var\mibs\at-smi.txt
       C:\NetXMS\var\mibs\at-stack.txt
       C:\NetXMS\var\mibs\at-switch.txt
       C:\NetXMS\var\mibs\at-sysinfo.txt
       C:\NetXMS\var\mibs\at-trigger.txt
       C:\NetXMS\var\mibs\at-tty.txt
       C:\NetXMS\var\mibs\BGP4-MIB.txt
       C:\NetXMS\var\mibs\BN-IF-EXTENSIONS-MIB.txt
       C:\NetXMS\var\mibs\BRIDGE-MIB.txt
       C:\NetXMS\var\mibs\CDX-6500-COMMON-MIB.txt
       C:\NetXMS\var\mibs\CHECKPOINT-NG-MIB.txt
       C:\NetXMS\var\mibs\CISCO-C2900-MIB.txt
       C:\NetXMS\var\mibs\CISCO-CDP-MIB.txt
       C:\NetXMS\var\mibs\CISCO-ENVMON-MIB.txt
       C:\NetXMS\var\mibs\CISCO-MEMORY-POOL-MIB.txt
       C:\NetXMS\var\mibs\CISCO-PING-MIB.txt
       C:\NetXMS\var\mibs\CISCO-PROCESS-MIB.txt
       C:\NetXMS\var\mibs\CISCO-PRODUCTS-MIB.txt
       C:\NetXMS\var\mibs\CISCO-QOS-PIB-MIB.txt
       C:\NetXMS\var\mibs\CISCO-SMI.txt
       C:\NetXMS\var\mibs\CISCO-SYSLOG-MIB.txt
       C:\NetXMS\var\mibs\CISCO-TC.txt
       C:\NetXMS\var\mibs\CISCO-TCP-MIB.txt
       C:\NetXMS\var\mibs\CISCO-VTP-MIB.txt
       C:\NetXMS\var\mibs\COSINE-GLOBAL-REG.txt
       C:\NetXMS\var\mibs\COSINE-InVision-MIB.txt
       C:\NetXMS\var\mibs\COSINE-ORION-MIB.txt
       C:\NetXMS\var\mibs\DS1-MIB.txt
       C:\NetXMS\var\mibs\DS3-MIB.txt
       C:\NetXMS\var\mibs\ENTITY-MIB.txt
       C:\NetXMS\var\mibs\FIBRE-CHANNEL-FE-MIB.txt
       C:\NetXMS\var\mibs\HOST-RESOURCES-MIB.txt
       C:\NetXMS\var\mibs\HOST-RESOURCES-TYPES.txt
       C:\NetXMS\var\mibs\IANA-ADDRESS-FAMILY-NUMBERS-MIB.txt
       C:\NetXMS\var\mibs\IANA-LANGUAGE-MIB.txt
       C:\NetXMS\var\mibs\IANA-RTPROTO-MIB.txt
       C:\NetXMS\var\mibs\IANAifType-MIB.txt
       C:\NetXMS\var\mibs\IEEE8021-PAE-MIB.txt
       C:\NetXMS\var\mibs\ieee8023-lag.txt
       C:\NetXMS\var\mibs\IEEE802dot11-MIB.txt
       C:\NetXMS\var\mibs\IF-MIB.txt
       C:\NetXMS\var\mibs\INET-ADDRESS-MIB.txt
       C:\NetXMS\var\mibs\IP-MIB.txt
       C:\NetXMS\var\mibs\IPMROUTE-STD-MIB.txt
       C:\NetXMS\var\mibs\LLDP-MIB.txt
       C:\NetXMS\var\mibs\lldp.txt
       C:\NetXMS\var\mibs\MAU-MIB.txt
       C:\NetXMS\var\mibs\MTA-MIB.txt
       C:\NetXMS\var\mibs\NET-SNMP-AGENT-MIB.txt
       C:\NetXMS\var\mibs\NET-SNMP-MIB.txt
       C:\NetXMS\var\mibs\NET-SNMP-MONITOR-MIB.txt
       C:\NetXMS\var\mibs\NET-SNMP-SYSTEM-MIB.txt
       C:\NetXMS\var\mibs\NET-SNMP-TC.txt
       C:\NetXMS\var\mibs\NETSCREEN-ADDR-MIB.txt
       C:\NetXMS\var\mibs\NETSCREEN-INTERFACE-MIB.txt
       C:\NetXMS\var\mibs\NETSCREEN-NAT-MIB.txt
       C:\NetXMS\var\mibs\NETSCREEN-PRODUCTS-MIB.txt
       C:\NetXMS\var\mibs\NETSCREEN-RESOURCE-MIB.txt
       C:\NetXMS\var\mibs\NETSCREEN-SCHEDULE-MIB.txt
       C:\NetXMS\var\mibs\NETSCREEN-SERVICE-MIB.txt
       C:\NetXMS\var\mibs\NETSCREEN-SMI.txt
       C:\NetXMS\var\mibs\NETSCREEN-TRAP-MIB.txt
       C:\NetXMS\var\mibs\NETSCREEN-VPN-MON-MIB.txt
       C:\NetXMS\var\mibs\NETSCREEN-VR-MIB.txt
       C:\NetXMS\var\mibs\NETSCREEN-VSYS-MIB.txt
       C:\NetXMS\var\mibs\NETWORK-SERVICES-MIB.txt
       C:\NetXMS\var\mibs\NOKIA-IPSO-REGISTRATION-MIB.txt
       C:\NetXMS\var\mibs\NOKIA-IPSO-SYSTEM-MIB.txt
       C:\NetXMS\var\mibs\OPTIMUX-MIB.txt
       C:\NetXMS\var\mibs\OSPF-MIB.txt
       C:\NetXMS\var\mibs\P-BRIDGE-MIB.txt
       C:\NetXMS\var\mibs\PerfHist-TC-MIB.txt
       C:\NetXMS\var\mibs\PIM-MIB.txt
       C:\NetXMS\var\mibs\portauth.txt
       C:\NetXMS\var\mibs\PowerNet-MIB.txt
       C:\NetXMS\var\mibs\Printer-MIB.txt
       C:\NetXMS\var\mibs\Q-BRIDGE-MIB.txt
       C:\NetXMS\var\mibs\RAPID-CITY.txt
       C:\NetXMS\var\mibs\RFC-1212.txt
       C:\NetXMS\var\mibs\RFC-1215.txt
       C:\NetXMS\var\mibs\RFC1155-SMI.txt
       C:\NetXMS\var\mibs\RFC1213-MIB.txt
       C:\NetXMS\var\mibs\rfc1213.txt
       C:\NetXMS\var\mibs\rfc1493.txt
       C:\NetXMS\var\mibs\rfc1643.txt
       C:\NetXMS\var\mibs\rfc1657.txt
       C:\NetXMS\var\mibs\rfc1850-ospf-traps.txt
       C:\NetXMS\var\mibs\rfc1850-ospf.txt
       C:\NetXMS\var\mibs\rfc2096.txt
       C:\NetXMS\var\mibs\rfc2239.txt
       C:\NetXMS\var\mibs\rfc2674q.txt
       C:\NetXMS\var\mibs\rfc2787.txt
       C:\NetXMS\var\mibs\rfc2790.txt
       C:\NetXMS\var\mibs\rfc2790t.txt
       C:\NetXMS\var\mibs\rfc2819.txt
       C:\NetXMS\var\mibs\rfc2863.txt
       C:\NetXMS\var\mibs\rfc3411.txt
       C:\NetXMS\var\mibs\rfc3412.txt
       C:\NetXMS\var\mibs\rfc3413n.txt
       C:\NetXMS\var\mibs\rfc3413p.txt
       C:\NetXMS\var\mibs\rfc3413t.txt
       C:\NetXMS\var\mibs\rfc3414.txt
       C:\NetXMS\var\mibs\rfc3415.txt
       C:\NetXMS\var\mibs\RMON-MIB.txt
       C:\NetXMS\var\mibs\RMON2-MIB.txt
       C:\NetXMS\var\mibs\RS-232-MIB.txt
       C:\NetXMS\var\mibs\ruzin-mstp-mib-04.txt
       C:\NetXMS\var\mibs\S5-CHASSIS-MIB.txt
       C:\NetXMS\var\mibs\S5-CHASSIS-TRAP-MIB.txt
       C:\NetXMS\var\mibs\S5-ETH-MULTISEG-TOPOLOGY-MIB.txt
       C:\NetXMS\var\mibs\S5-ETH-REDUNDANT-LINKS-MIB.txt
       C:\NetXMS\var\mibs\S5-ETHERNET-COMMON-MIB.txt
       C:\NetXMS\var\mibs\S5-ETHERNET-MIB.txt
       C:\NetXMS\var\mibs\S5-ETHERNET-TRAP-MIB.txt
       C:\NetXMS\var\mibs\S5-REG-MIB.txt
       C:\NetXMS\var\mibs\S5-ROOT-MIB.txt
       C:\NetXMS\var\mibs\S5-SWITCH-BAYSECURE-MIB.txt
       C:\NetXMS\var\mibs\S5-TCS-MIB.txt
       C:\NetXMS\var\mibs\SNMP-COMMUNITY-MIB.txt
       C:\NetXMS\var\mibs\SNMP-FRAMEWORK-MIB.txt
       C:\NetXMS\var\mibs\SNMP-PROXY-MIB.txt
       C:\NetXMS\var\mibs\SNMP-REPEATER-MIB.txt
       C:\NetXMS\var\mibs\SNMP-TARGET-MIB.txt
       C:\NetXMS\var\mibs\SNMP-USER-BASED-SM-MIB.txt
       C:\NetXMS\var\mibs\SNMPv2-CONF.txt
       C:\NetXMS\var\mibs\SNMPv2-MIB.txt
       C:\NetXMS\var\mibs\SNMPv2-SMI.txt
       C:\NetXMS\var\mibs\SNMPv2-TC.txt
       C:\NetXMS\var\mibs\SNMPv2-TM.txt
       C:\NetXMS\var\mibs\SW-MIB.txt
       C:\NetXMS\var\mibs\SYNOPTICS-COMMON-MIB.txt
       C:\NetXMS\var\mibs\SYNOPTICS-ROOT-MIB.txt
       C:\NetXMS\var\mibs\TCP-MIB.txt
       C:\NetXMS\var\mibs\TOKEN-RING-RMON-MIB.txt
       C:\NetXMS\var\mibs\TUNNEL-MIB.txt
       C:\NetXMS\var\mibs\UCD-DISKIO-MIB.txt
       C:\NetXMS\var\mibs\UCD-DLMOD-MIB.txt
       C:\NetXMS\var\mibs\UCD-IPFILTER-MIB.txt
       C:\NetXMS\var\mibs\UCD-IPFWACC-MIB.txt
       C:\NetXMS\var\mibs\UCD-SNMP-MIB.txt
       C:\NetXMS\var\mibs\UDP-MIB.txt
       C:\NetXMS\var\mibs\UPS-MIB.txt
       C:\NetXMS\var\mibs\USEC-MIB.txt
       C:\NetXMS\var\mibs\V2ADMIN-MIB.txt
       C:\NetXMS\var\mibs\WF-COM.txt
       C:\NetXMS\var\mibs\WWW-MIB.txt
    Resolving imports:
       ARCADA-MIB
       AT-BOARDS-MIB
       AT-DHCP-MIB
       AT-ENVMON-MIB
       AT-EPSR-MIB
       AT-ETH-MIB
       AT-FILE-MIB
       AT-FLASH-MIB
       AT-INSTALL-MIB
       AT-INTERFACES-MIB
       AT-LOADER-MIB
       AT-PAE-MIB
       AT-PIM-MIB
       AT-PING-MIB
       AT-PRODUCT-MIB
       AT-QOS-MIB
       AT-SMI-MIB
       AT-STACK-MIB
       AT-SWITCH-MIB
       AT-SYSINFO-MIB
       AT-TRIGGER-MIB
       AT-TTY-MIB
       BGP4-MIB
       BN-IF-EXTENSIONS-MIB
       BRIDGE-MIB
       CDX-6500-COMMON-MIB
       CHECKPOINT-MIB
       CISCO-C2900-MIB
       CISCO-CDP-MIB
       CISCO-ENVMON-MIB
       CISCO-MEMORY-POOL-MIB
       CISCO-PING-MIB
       CISCO-PROCESS-MIB
       CISCO-PRODUCTS-MIB
       CISCO-QOS-PIB-MIB
       CISCO-SMI
       CISCO-SYSLOG-MIB
       CISCO-TC
       CISCO-TCP-MIB
       CISCO-VTP-MIB
       COSINE-GLOBAL-REG
       COSINE-InVision-MIB
       COSINE-ORION-MIB
       DS1-MIB
       DS3-MIB
       ENTITY-MIB
       FIBRE-CHANNEL-FE-MIB
       HOST-RESOURCES-MIB
       HOST-RESOURCES-TYPES
       IANA-ADDRESS-FAMILY-NUMBERS-MIB
       IANA-LANGUAGE-MIB
       IANA-RTPROTO-MIB
       IANAifType-MIB
       IEEE8021-PAE-MIB
       IEEE8023-LAG-MIB
    IEEE8023-LAG-MIB: ERROR 001: Import symbol "BITS" unresolved
    
    C:\NetXMS\var\test>
    

    Файлик приложил.


    ieee8023-lag.zip


  • Ошибка при компиляции mib'a от ATI
    B badland
    Support (Russian)

    Хы, пост на мне у тебя хороший получился. Номерок понравился )).

    rfc3412.mib скинул.

    Стер все от BEGIN до END, ошибка осталась. На 150-ю строку. Короче я закоментил весь низ, тогда съело...

    Снова ошибка вылезла:

    AT-PIM-MIB: ERROR 002: Import module "PIM-MIB" unresolved

    C:\NetXMS\var\mibs\UPS-MIB.txt
       C:\NetXMS\var\mibs\USEC-MIB.txt
       C:\NetXMS\var\mibs\V2ADMIN-MIB.txt
       C:\NetXMS\var\mibs\WF-COM.txt
       C:\NetXMS\var\mibs\WWW-MIB.txt
    Resolving imports:
       ARCADA-MIB
       AT-BOARDS-MIB
       AT-DHCP-MIB
       AT-ENVMON-MIB
       AT-EPSR-MIB
       AT-ETH-MIB
       AT-FILE-MIB
       AT-FLASH-MIB
       AT-INSTALL-MIB
       AT-INTERFACES-MIB
       AT-LOADER-MIB
       AT-PAE-MIB
       AT-PIM-MIB
    AT-PIM-MIB: ERROR 002: Import module "PIM-MIB" unresolved
    

    хотя миба лежит, модуль правильно назван в нутри. Вообщем фаил приложил: at-pim.zip

    Спасибо огромное за помощь!


    at-pim.zip


  • Ошибка при компиляции mib'a от ATI
    B badland
    Support (Russian)

    Спасибо за ответ.

    Я в ASN'е не силен, но решил проблему еще в тот день подстановкой sysDesc в место { }. Вроде прокатило.  ;D

    Еще вопрос:

    C:\NetXMS\var\mibs\rfc3412.txt: ERROR 003: Parser error - syntax error, unexpect
    ed UCASEFIRST_IDENT_SYM, expecting $end in line 150

    150 строчка это "SNMPv3MessageSyntax DEFINITIONS IMPLICIT TAGS ::= BEGIN". К сожалению с синтаксисом я не знаком, но сделал так:

    -- SNMPv3MessageSyntax DEFINITIONS IMPLICIT TAGS ::= BEGIN, строка с ошибкой просто сползла ниже, тогда сделал так:

    -- SNMPv3MessageSyntax
              DEFINITIONS IMPLICIT TAGS ::= BEGIN
    , тоже самое.

    -- The SNMPv3 Message Format
    
    -- This section defines the SNMPv3 message format and the corresponding
    -- SNMP version 3 Message Processing Model (v3MP).
    
     SNMPv3MessageSyntax DEFINITIONS IMPLICIT TAGS ::= BEGIN
    
        SNMPv3Message ::= SEQUENCE {
            -- identify the layout of the SNMPv3Message
            -- this element is in same position as in SNMPv1
            -- and SNMPv2c, allowing recognition
            -- the value 3 is used for snmpv3
            msgVersion INTEGER ( 0 .. 2147483647 ),
            -- administrative parameters
            msgGlobalData HeaderData,
            -- security model-specific parameters
            -- format defined by Security Model
            msgSecurityParameters OCTET STRING,
            msgData  ScopedPduData
        }
    
        HeaderData ::= SEQUENCE {
            msgID      INTEGER (0..2147483647),
            msgMaxSize INTEGER (484..2147483647),
    
            msgFlags   OCTET STRING (SIZE(1)),
                       --  .... ...1   authFlag
                       --  .... ..1.   privFlag
                       --  .... .1..   reportableFlag
                       --              Please observe:
                       --  .... ..00   is OK, means noAuthNoPriv
                       --  .... ..01   is OK, means authNoPriv
                       --  .... ..10   reserved, MUST NOT be used.
                       --  .... ..11   is OK, means authPriv
    
            msgSecurityModel INTEGER (1..2147483647)
        }
    
        ScopedPduData ::= CHOICE {
            plaintext    ScopedPDU,
            encryptedPDU OCTET STRING  -- encrypted scopedPDU value
        }
    
        ScopedPDU ::= SEQUENCE {
            contextEngineID  OCTET STRING,
            contextName      OCTET STRING,
            data             ANY -- e.g., PDUs as defined in [RFC3416]
        }
    END
    

    Вообще мибы у элайта уе***ские. Вероятно их кодеры считают, что коментить коменты - верх маразма = ). Заколебался за ними подправлять.


  • Ошибка при компиляции mib'a от ATI
    B badland
    Support (Russian)

    С этим файлом все, ппц ошибок в нем. Теперь у меня точно ступор:

    lldpPortConfigTLVsTxEnable OBJECT-TYPE
        SYNTAX      BITS {
                portDesc(0),
                sysName(1),
                sysDesc(2),
                sysCap(3)
        }
        MAX-ACCESS  read-write
        STATUS      current
        DESCRIPTION
                "The lldpPortConfigTLVsTxEnable, defined as a bitmap,
                includes the basic set of LLDP TLVs whose transmission is
                allowed on the local LLDP agent by the network management.
                Each bit in the bitmap corresponds to a TLV type associated
                with a specific optional TLV.

                It should be noted that the organizationally-specific TLVs
                are excluded from the lldpTLVsTxEnable bitmap.
               
                LLDP Organization Specific Information Extension MIBs should
                have similar configuration object to control transmission
                of their organizationally defined TLVs.

                The bit 'portDesc(0)' indicates that LLDP agent should
                transmit 'Port Description TLV'.

                The bit 'sysName(1)' indicates that LLDP agent should transmit
                'System Name TLV'.

                The bit 'sysDesc(2)' indicates that LLDP agent should transmit
                'System Description TLV'.

                The bit 'sysCap(3)' indicates that LLDP agent should transmit
                'System Capabilities TLV'.

                There is no bit reserved for the management address TLV type
                since transmission of management address TLVs are controlled
                by another object, lldpConfigManAddrTable.

                The default value for lldpPortConfigTLVsTxEnable object is
                empty set, which means no enumerated values are set.

                The value of this object must be restored from non-volatile
                storage after a re-initialization of the management system."
        REFERENCE
                "IEEE 802.1AB-2004 10.2.1.1"
        DEFVAL  { { } } <-- Вот на эту строчку ругается
        ::= { lldpPortConfigEntry 4 }

    C:\NetXMS\var\mibs\lldp.txt: ERROR 003: Parser error - syntax error, unexpected
    RIGHT_BRACE_SYM, expecting IMPLIED_SYM or UCASEFIRST_IDENT_SYM or LCASEFIRST_IDE
    NT_SYM in line 729


  • Ошибка при компиляции mib'a от ATI
    B badland
    Support (Russian)

    Хм... заменил "кривые" ковычки на нормальные, теперь выдается ошибка такая:

    C:\NetXMS\var\mibs\ieee8023-lag.txt: ERROR 003: Parser error - syntax error, unexpected UCASEFIRST_IDENT_SYM, expecting ASSIGNMENT_SYM in line 256


  • Ошибка при компиляции mib'a от ATI
    B badland
    Support (Russian)

    Добрый день.

    Версия программы: 0.2.21

    С дисков от свитчей alliedtelesyn'а слил мибы в C:\NetXMS\var\mibs и переименовал .mib -> .txt
    Выполнил команду:

    C:\NetXMS\var\test>C:\NetXMS\bin\nxmibc.exe -d C:\NetXMS\var\mibs -o C:\NetXMS\var\mibs\netxms.mib -z

    пробовал и такую: C:\NetXMS\var\test>C:\NetXMS\bin\nxmibc.exe -d C:\NetXMS\var\mibs -z

    Беда:
    C:\NetXMS\var\mibs\ieee8023-lag.txt: ERROR 003: Parser error - syntax error, unexpected NUMBER_SYM, expecting CSTRING_SYM in line 24

    Фаил приложен.

    Спасибо.


    ieee8023-lag.zip

  • Login

  • Don't have an account? Register

  • Login or register to search.
Powered by NodeBB Contributors
  • First post
    Last post
0
  • Categories
  • Recent
  • Tags
  • Popular
  • Users
  • Groups