About 2MB. Will send an e-mail
QACit
Posts
-
Beginner to SNMP for switches -
Beginner to SNMP for switchesOkay. The BGP-4 mib is a default mib with the NETXMS install. Can I just remove it from the compiler?
-
Beginner to SNMP for switchesThank you. Here is the next trouble:
C:\XMS\bin>nxmibc -d C:\XMS\var\mibs -z
NetXMS MIB Compiler Version 0.2.21
Copyright (c) 2005, 2006 Victor KirhenshteinParsing source files:
C:\XMS\var\mibs\ARCADA-MIB.txt
C:\XMS\var\mibs\BGP4-MIB.txt
C:\XMS\var\mibs\BN-IF-EXTENSIONS-MIB.txt
C:\XMS\var\mibs\BRIDGE-MIB.txt
C:\XMS\var\mibs\CDX-6500-COMMON-MIB.txt
C:\XMS\var\mibs\CHECKPOINT-NG-MIB.txt
C:\XMS\var\mibs\CISCO-C2900-MIB.txt
C:\XMS\var\mibs\CISCO-CDP-MIB.txt
C:\XMS\var\mibs\CISCO-ENVMON-MIB.txt
C:\XMS\var\mibs\CISCO-MEMORY-POOL-MIB.txt
C:\XMS\var\mibs\CISCO-PING-MIB.txt
C:\XMS\var\mibs\CISCO-PROCESS-MIB.txt
C:\XMS\var\mibs\CISCO-PRODUCTS-MIB.txt
C:\XMS\var\mibs\CISCO-QOS-PIB-MIB.txt
C:\XMS\var\mibs\CISCO-SMI.txt
C:\XMS\var\mibs\CISCO-SYSLOG-MIB.txt
C:\XMS\var\mibs\CISCO-TC.txt
C:\XMS\var\mibs\CISCO-TCP-MIB.txt
C:\XMS\var\mibs\CISCO-VTP-MIB.txt
C:\XMS\var\mibs\COSINE-GLOBAL-REG.txt
C:\XMS\var\mibs\COSINE-InVision-MIB.txt
C:\XMS\var\mibs\COSINE-ORION-MIB.txt
C:\XMS\var\mibs\DS1-MIB.txt
C:\XMS\var\mibs\DS3-MIB.txt
C:\XMS\var\mibs\ENTITY-MIB.txt
C:\XMS\var\mibs\FIBRE-CHANNEL-FE-MIB.txt
C:\XMS\var\mibs\HOST-RESOURCES-MIB.txt
C:\XMS\var\mibs\HOST-RESOURCES-TYPES.txt
C:\XMS\var\mibs\hpAcmxlBase-mib.txt
C:\XMS\var\mibs\hpAcmxlIfExt-mib.txt
C:\XMS\var\mibs\hpAcmxlMemProc-mib.txt
C:\XMS\var\mibs\hpAcmxlSystem-mib.txt
C:\XMS\var\mibs\hpentmib-mib.txt
C:\XMS\var\mibs\hpHttpMg-mib.txt
C:\XMS\var\mibs\hpicf8023Rptr-mib.txt
C:\XMS\var\mibs\hpicfArpProtect-mib.txt
C:\XMS\var\mibs\hpicfAutorun-mib.txt
C:\XMS\var\mibs\hpicfAutz-mib.txt
C:\XMS\var\mibs\hpicfBasic-mib.txt
C:\XMS\var\mibs\hpicfBridge-mib.txt
C:\XMS\var\mibs\hpicfChain-mib.txt
C:\XMS\var\mibs\hpicfChassis-mib.txt
C:\XMS\var\mibs\hpicfConnectionRateFilter-mib.txt
C:\XMS\var\mibs\hpicfDot1x-mib.txt
C:\XMS\var\mibs\hpicfDownload-mib.txt
C:\XMS\var\mibs\hpicfEtwist-mib.txt
C:\XMS\var\mibs\hpicfFf-mib.txt
C:\XMS\var\mibs\hpicfGenRptr-mib.txt
C:\XMS\var\mibs\hpicfGppc-mib.txt
C:\XMS\var\mibs\hpicfHighAvailability-mib.txt
C:\XMS\var\mibs\hpicfInstMon-mib.txt
C:\XMS\var\mibs\hpicfIpAddress-mib.txt
C:\XMS\var\mibs\hpicfIpRoute-mib.txt
C:\XMS\var\mibs\hpicfJumbo-mib.txt
C:\XMS\var\mibs\hpicfL3MacConfig-mib.txt
C:\XMS\var\mibs\hpicfLinktest-mib.txt
C:\XMS\var\mibs\hpicfMld-mib.txt
C:\XMS\var\mibs\hpicfOid-mib.txt
C:\XMS\var\mibs\IANA-ADDRESS-FAMILY-NUMBERS-MIB.txt
C:\XMS\var\mibs\IANA-LANGUAGE-MIB.txt
C:\XMS\var\mibs\ianaAFN-mib.txt
C:\XMS\var\mibs\IANAifType-MIB.txt
C:\XMS\var\mibs\ianaiprouteprotocol-mib.txt
C:\XMS\var\mibs\IEEE8021-PAE-MIB.txt
C:\XMS\var\mibs\ieee80211-mib.txt
C:\XMS\var\mibs\ieee8023lag-mib.txt
C:\XMS\var\mibs\ieee802af-mib.txt
C:\XMS\var\mibs\IEEE802dot11-MIB.txt.txt
C:\XMS\var\mibs\IF-MIB.txt
C:\XMS\var\mibs\INET-ADDRESS-MIB.txt
C:\XMS\var\mibs\IP-MIB.txt
C:\XMS\var\mibs\LLDP-MIB.txt
C:\XMS\var\mibs\MAU-MIB.txt
C:\XMS\var\mibs\MTA-MIB.txt
C:\XMS\var\mibs\NET-SNMP-AGENT-MIB.txt
C:\XMS\var\mibs\NET-SNMP-MIB.txt
C:\XMS\var\mibs\NET-SNMP-MONITOR-MIB.txt
C:\XMS\var\mibs\NET-SNMP-SYSTEM-MIB.txt
C:\XMS\var\mibs\NET-SNMP-TC.txt
C:\XMS\var\mibs\NETSCREEN-ADDR-MIB.txt
C:\XMS\var\mibs\NETSCREEN-INTERFACE-MIB.txt
C:\XMS\var\mibs\NETSCREEN-NAT-MIB.txt
C:\XMS\var\mibs\NETSCREEN-PRODUCTS-MIB.txt
C:\XMS\var\mibs\NETSCREEN-RESOURCE-MIB.txt
C:\XMS\var\mibs\NETSCREEN-SCHEDULE-MIB.txt
C:\XMS\var\mibs\NETSCREEN-SERVICE-MIB.txt
C:\XMS\var\mibs\NETSCREEN-SMI.txt
C:\XMS\var\mibs\NETSCREEN-TRAP-MIB.txt
C:\XMS\var\mibs\NETSCREEN-VPN-MON-MIB.txt
C:\XMS\var\mibs\NETSCREEN-VR-MIB.txt
C:\XMS\var\mibs\NETSCREEN-VSYS-MIB.txt
C:\XMS\var\mibs\NETWORK-SERVICES-MIB.txt
C:\XMS\var\mibs\NOKIA-IPSO-REGISTRATION-MIB.txt
C:\XMS\var\mibs\NOKIA-IPSO-SYSTEM-MIB.txt
C:\XMS\var\mibs\OPTIMUX-MIB.txt
C:\XMS\var\mibs\OSPF-MIB.txt
C:\XMS\var\mibs\P-BRIDGE-MIB.txt
C:\XMS\var\mibs\PerfHist-TC-MIB.txt
C:\XMS\var\mibs\PowerNet-MIB.txt
C:\XMS\var\mibs\Printer-MIB.txt
C:\XMS\var\mibs\Q-BRIDGE-MIB.txt
C:\XMS\var\mibs\RAPID-CITY.txt
C:\XMS\var\mibs\RFC-1212.txt
C:\XMS\var\mibs\RFC-1215.txt
C:\XMS\var\mibs\RFC1155-SMI.txt
C:\XMS\var\mibs\rfc1213-mib.txt
C:\XMS\var\mibs\rfc1493-mib.txt
C:\XMS\var\mibs\rfc1512-mib.txt
C:\XMS\var\mibs\rfc1513-mib.txt
C:\XMS\var\mibs\rfc1724-mib.txt
C:\XMS\var\mibs\rfc1742-mib.txt
C:\XMS\var\mibs\rfc1749-mib.txt
C:\XMS\var\mibs\rfc1850-mib.txt
C:\XMS\var\mibs\rfc1850b-mib.txt
C:\XMS\var\mibs\rfc2011D10-mib.txt
C:\XMS\var\mibs\rfc2012-mib.txt
C:\XMS\var\mibs\rfc2013-mib.txt
C:\XMS\var\mibs\rfc2020-mib.txt
C:\XMS\var\mibs\rfc2021-mib.txt
C:\XMS\var\mibs\rfc2096-07.mib.txt
C:\XMS\var\mibs\rfc2108-mib.txt
C:\XMS\var\mibs\rfc2266-mib.txt
C:\XMS\var\mibs\rfc2576-mib.txt
C:\XMS\var\mibs\rfc2578-mib.txt
C:\XMS\var\mibs\rfc2579-mib.txt
C:\XMS\var\mibs\rfc2613-mib.txt
C:\XMS\var\mibs\rfc2618-mib.txt
C:\XMS\var\mibs\rfc2620-mib.txt
C:\XMS\var\mibs\rfc2665-mib.txt
C:\XMS\var\mibs\rfc2674_p-mib.txt
C:\XMS\var\mibs\rfc2674_q-mib.txt
C:\XMS\var\mibs\rfc2737-mib.txt
C:\XMS\var\mibs\rfc2787-mib.txt
C:\XMS\var\mibs\rfc2819-mib.txt
C:\XMS\var\mibs\rfc2856-mib.txt
C:\XMS\var\mibs\rfc2863-mib.txt
C:\XMS\var\mibs\rfc2925a-mib.txt
C:\XMS\var\mibs\rfc2932-mib.txt
C:\XMS\var\mibs\rfc2934-mib.txt
C:\XMS\var\mibs\rfc3019-mib.txt
C:\XMS\var\mibs\rfc3273-mib.txt
C:\XMS\var\mibs\rfc3291D06-mib.txt
C:\XMS\var\mibs\rfc3411-mib.txt
C:\XMS\var\mibs\rfc3412-mib.txt
C:\XMS\var\mibs\rfc3413a-mib.txt
C:\XMS\var\mibs\rfc3413b-mib.txt
C:\XMS\var\mibs\rfc3414-mib.txt
C:\XMS\var\mibs\rfc3415-mib.txt
C:\XMS\var\mibs\rfc3417-mib.txt
C:\XMS\var\mibs\rfc3418-mib.txt
C:\XMS\var\mibs\rfc3433-mib.txt
C:\XMS\var\mibs\rfc3595-mib.txt
C:\XMS\var\mibs\rfc3636-mib.txt
C:\XMS\var\mibs\rfc4022-mib.txt
C:\XMS\var\mibs\rfc4087-mib.txt
C:\XMS\var\mibs\rfc4113-mib.txt
C:\XMS\var\mibs\rfc4268-mib.txt
C:\XMS\var\mibs\rfc4673-mib.txt
C:\XMS\var\mibs\rfc4750-mib.txt
C:\XMS\var\mibs\RMON-MIB.txt
C:\XMS\var\mibs\RMON2-MIB.txt
C:\XMS\var\mibs\RS-232-MIB.txt
C:\XMS\var\mibs\S5-CHASSIS-MIB.txt
C:\XMS\var\mibs\S5-CHASSIS-TRAP-MIB.txt
C:\XMS\var\mibs\S5-ETH-MULTISEG-TOPOLOGY-MIB.txt
C:\XMS\var\mibs\S5-ETH-REDUNDANT-LINKS-MIB.txt
C:\XMS\var\mibs\S5-ETHERNET-COMMON-MIB.txt
C:\XMS\var\mibs\S5-ETHERNET-MIB.txt
C:\XMS\var\mibs\S5-ETHERNET-TRAP-MIB.txt
C:\XMS\var\mibs\S5-REG-MIB.txt
C:\XMS\var\mibs\S5-ROOT-MIB.txt
C:\XMS\var\mibs\S5-SWITCH-BAYSECURE-MIB.txt
C:\XMS\var\mibs\S5-TCS-MIB.txt
C:\XMS\var\mibs\sflow-mib.txt
C:\XMS\var\mibs\SNMP-COMMUNITY-MIB.txt
C:\XMS\var\mibs\SNMP-FRAMEWORK-MIB.txt
C:\XMS\var\mibs\SNMP-PROXY-MIB.txt
C:\XMS\var\mibs\SNMP-REPEATER-MIB.txt
C:\XMS\var\mibs\SNMP-TARGET-MIB.txt
C:\XMS\var\mibs\SNMP-USER-BASED-SM-MIB.txt
C:\XMS\var\mibs\SNMPv2-CONF.txt
C:\XMS\var\mibs\SNMPv2-MIB.txt
C:\XMS\var\mibs\SNMPv2-SMI.txt
C:\XMS\var\mibs\SNMPv2-TC.txt
C:\XMS\var\mibs\SNMPv2-TM.txt
C:\XMS\var\mibs\SW-MIB.txt
C:\XMS\var\mibs\SYNOPTICS-COMMON-MIB.txt
C:\XMS\var\mibs\SYNOPTICS-ROOT-MIB.txt
C:\XMS\var\mibs\TCP-MIB.txt
C:\XMS\var\mibs\TOKEN-RING-RMON-MIB.txt
C:\XMS\var\mibs\TUNNEL-MIB.txt
C:\XMS\var\mibs\UCD-DISKIO-MIB.txt
C:\XMS\var\mibs\UCD-DLMOD-MIB.txt
C:\XMS\var\mibs\UCD-IPFILTER-MIB.txt
C:\XMS\var\mibs\UCD-IPFWACC-MIB.txt
C:\XMS\var\mibs\UCD-SNMP-MIB.txt
C:\XMS\var\mibs\UDP-MIB.txt
C:\XMS\var\mibs\UPS-MIB.txt
C:\XMS\var\mibs\USEC-MIB.txt
C:\XMS\var\mibs\V2ADMIN-MIB.txt
C:\XMS\var\mibs\WF-COM.txt
C:\XMS\var\mibs\WWW-MIB.txt
Resolving imports:
ARCADA-MIB
BGP4-MIB
BGP4-MIB: ERROR 001: Import symbol "MODULE-IDENTITY" unresolved -
Beginner to SNMP for switchesI ran the compiler (nxmibc -d C:\XMS\var\mibs\ -z) and when it is done I re-open the console, right-click on the switch, click data collection. then New, but I don't know where to look for the HP MIBS. Also, how do I know that the compiler completed?
-
Beginner to SNMP for switchesThanks Victor. I have about 15 HP ProCurve switches that I want to monitor. How do HP MIB's fit into configuration and DCI's?
-
Beginner to SNMP for switchesAll SNMP gurus. I am very new to SNMP and monitoring. I recently lodaed NetXMS on a Win XP machine with SQL Express 2005. I would like to be proactive with our network and would like to start by monitoring our HP Procurve switches. I would like to get basic info like high errors on a port, duplex issues, port down, or port utilization and then have an e-mail sent to me if thresholds are exceeded. It is just that I am really clueless on how to tailor this for what I need. I would just like to add one device at a time and then run a test or two to verify results. I am missing something between the users guide and what I actually need to do. Any help would be greatly appreciated. ???
Jason