Skip to content
  • Categories
  • Recent
  • Tags
  • Popular
  • Users
  • Groups
Skins
  • Light
  • Brite
  • Cerulean
  • Cosmo
  • Flatly
  • Journal
  • Litera
  • Lumen
  • Lux
  • Materia
  • Minty
  • Morph
  • Pulse
  • Sandstone
  • Simplex
  • Sketchy
  • Spacelab
  • United
  • Yeti
  • Zephyr
  • Dark
  • Cyborg
  • Darkly
  • Quartz
  • Slate
  • Solar
  • Superhero
  • Vapor

  • Default (Flatly)
  • No Skin
Collapse
Brand Logo

NetXMS Forum

  1. Home
  2. Support
  3. MIB comiling nightmare (part 01)

MIB comiling nightmare (part 01)

Scheduled Pinned Locked Moved Support
4 Posts 3 Posters 60.1k Views
  • Oldest to Newest
  • Newest to Oldest
  • Most Votes
Reply
  • Reply as topic
Log in to reply
This topic has been deleted. Only users with topic management privileges can see it.
  • Y
    Y
    yordi
    wrote on last edited by
    #1

    Hello,
    First off, Netxms is a really great tool !
    I use it for our school (32 Cisco SG300 series switches, 1 Catalys c2960 , )
    but the power comes from DCI and thus MIB..
    that last one is really problematic ...
    i have literary try for hours to compile MIB for our Cisco SMB switchen (SG300 series ) and our UPS ..
    after hours of trying, manual fix syntax error --> http://www.ibr.cs.tu-bs.de/bin/smitools.cgi upload mib file to this site to test the syntax ..
    At last i have deleted the mib files and the compiled one in de mibs folder (/usr/share/netxms/mibs)
    just adding the MIB for the UPS (infosec) UPSmib.txt ,  not compiling needing SNMPv2-SMI.txt and RFC115-SMI.txt and RFC1682.txt ..
    after searching on the internet found these but do not work .. pff
    After testing the UPSmib.txt there was a problem with the "COMPANYMIB: ERROR 001: Import symbol "MODULE-IDENTITY" unresolved "
    follow this website to trey the module-identity error.. fix some syntax but nothing helps .. http://www.muonics.com/Docs/MIBSmithy/UserGuide/moduleids.php
    Try to Resolved this issue with adding the MODULE-IDENTITY but still this error .. adding the Cisco sg300 MIB errors ...
    Who has expert skils to fix this ... or help me ?
    Is there a way to download the correct MIB that are included in the Netxms distribution ? or how to restore de default MIB ?
    i attached the MIB for Cisco SMB and UPS Infosec
    Also i found this link of de MIB of Netxms but how do you download all this MIB ? without one by one opening an copy-past tot text file ??
    http://git.netxms.org/public/netxms.git/tree/refs/heads/develop:/contrib/mibs?js=1
    Ho to convert MIB V1 or V2 to V3 so that Netxms accept it ?
    i have the latest NETXMS server installed on Linux
    Use management console on windows workstations and android.

    The Cisco MIB zip file is not uploading ! error 413 here is my onedrive link to the file ! --> https://1drv.ms/u/s!Aj037gJtNd7Bpe0gaqkQuZqp2XsRMg


    infosec-mib-original.zip

    1 Reply Last reply
    0
    • V
      V
      Victor Kirhenshtein
      wrote on last edited by
      #2

      Hi,

      you can restore original MIBs by downloading source package and extracting MIBs - they are under contrib/mibs. You don't need RFC-1628 MIB - it is already included.

      Seems that whoever builds Infosec MIB you have provided just took some template without much thinking - leaving "companyName" placeholder instead of replacing it with actual company name. I changed it to "infosec" and MIB name to INFOSEC-UPS, and fixed few other errors. Correct MIB attached.

      Best regards,
      Victor


      INFOSEC-UPS.txt

      1 Reply Last reply
      0
      • Y
        Y
        yordi
        wrote on last edited by
        #3

        Thank You allot,

        No i can use DCI on my switches and UPS.

        1 Reply Last reply
        0
        • A
          A
          albertosilva
          wrote on last edited by
          #4

          Hi Victor,

          I was talking to you about the Juniper Switches Vlans.. I found the mib for it and I'm getting the data when I do the walk, but the data is not going to the Vlan field on the interfaces menu. the OID is .1.3.6.1.4.1.2636.3.48.1.3.1.1.3
          With this we can get the Vlan Tags. For the HPs I have everything looks good, just the Junipers are not getting the Vlans. Is there something I can do, collect data maybe?

          Thanks.

          1 Reply Last reply
          0

          Hello! It looks like you're interested in this conversation, but you don't have an account yet.

          Getting fed up of having to scroll through the same posts each visit? When you register for an account, you'll always come back to exactly where you were before, and choose to be notified of new replies (either via email, or push notification). You'll also be able to save bookmarks and upvote posts to show your appreciation to other community members.

          With your input, this post could be even better 💗

          Register Login
          Reply
          • Reply as topic
          Log in to reply
          • Oldest to Newest
          • Newest to Oldest
          • Most Votes


          • Login

          • Don't have an account? Register

          • Login or register to search.
          Powered by NodeBB Contributors
          • First post
            Last post
          0
          • Categories
          • Recent
          • Tags
          • Popular
          • Users
          • Groups